Unito Pricing page can't be accessed from Mirror power-up and Export & Sync power-up
Incident Report for Unito
Resolved
This incident has been resolved.
Posted May 15, 2023 - 15:17 UTC
Investigating
We are currently investigating an issue preventing customers from accessing the Unito pricing page from the Mirror power-up and the Export & Sync power-up.

Unito syncing capabilities are not affected and your changes will be syncing normally.

We will update this page as soon as we know more.
Posted May 15, 2023 - 14:41 UTC
This incident affected: Unito Trello Powerup.