Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 04, 2026 - 01:00 UTC
Scheduled
We're performing brief maintenance on our sync services. Syncing will pause temporarily while the app stays available. We expect the pause to be below 15 minutes and there will be no action needed on your end.
Posted Jun 01, 2026 - 19:28 UTC
This scheduled maintenance affected: Unito Syncing Service, Unito Flow Status, Unito Streamed Attachments, and Unito Trello Powerup.