Google Sheets and Calendar flows degraded

Incident Report for Unito

Resolved

According to their status page, Google Cloud has resolved the issues that were impacting flows. Unito flows involving Google Sheets and Google Calendar are back up and running smoothly.
Posted Jun 13, 2025 - 00:52 UTC

Monitoring

According to their status page, Google Cloud is currently experiencing difficulties.

https://status.cloud.google.com/

Flows connected to Google Cloud tools (Google Sheets, Calendar) may be slower than usual or stop syncing completely. They should return to normal as soon as Google Cloud is back up and running.

Unito users not connected to Google Sheets or Calendar should not be affected in any way.
Posted Jun 12, 2025 - 19:02 UTC
This incident affected: Unito Syncing Service.